#248 — .mo files missing from egg

State Resolved
Version: 2.0.1
Area Functionality
Issue type Bug
Severity Medium
Submitted by Bas Roijen
Submitted on Mar 01, 2011
Responsible Maurits van Rees
Target release:
The .po files aren't compiled in the egg on PyPI.
Translations will not work unless autogeneration of .mo files is explicitly turned on in the buildout.
Added by Maurits van Rees on Sep 06, 2011 09:05 PM
Issue state: UnconfirmedConfirmed
Responsible manager: (UNASSIGNED)maurits
I was going to say that I had solved this meanwhile, but apparently I have not. I have got zest.releaser with zest.pocompile set up for releasing though, so this should work fine next time.

Let's check that. Okay, I had completely forgotten that I need to add a MANIFEST.in file for this to work, like mentioned in http://pypi.python.org/pypi/zest.pocompile

Fixed in r244221. I'll leave this issue open so I hopefully remember to check if this has really worked when I do the next release.
Added by Maurits van Rees on Oct 18, 2013 05:42 PM
Issue state: ConfirmedResolved
This is going fine now.

No responses can be added.