#160 — Migration Problems

State Resolved
Version: 1.1
Area Functionality
Issue type Bug
Severity Important
Submitted by Kevin Strasser
Submitted on Dec 13, 2007
Responsible Maurits van Rees
Target release: 1.1
Attempting to migrate from Poi 1.0rc2 svn/unreleased build 2 to 1.1 rc 2. When running the archetype_tool schema update I end up with the following error:

TypeError: can't pickle code objects

Then I tried to update each piece of Poi once at a time. It worked for the first three (Poi.PoiIssue, Poi.PoiPscTracker, Poi.PoiResponse) once I got to updating the schema for Poi.PoiTracker I ended up with the same error. Here is the traceback for it:

Traceback (innermost last):
  Module ZPublisher.Publish, line 121, in publish
  Module Zope2.App.startup, line 240, in commit
  Module transaction._manager, line 96, in commit
  Module transaction._transaction, line 380, in commit
  Module transaction._transaction, line 378, in commit
  Module transaction._transaction, line 433, in _commitResources
  Module ZODB.Connection, line 484, in commit
  Module ZODB.Connection, line 526, in _commit
  Module ZODB.Connection, line 553, in _store_objects
  Module ZODB.serialize, line 407, in serialize
  Module ZODB.serialize, line 416, in _dump
  Module copy_reg, line 69, in _reduce_ex
TypeError: can't pickle code objects

I am running the following versions:

Plone 2.5.2,
Zope (Zope 2.9.6-final, python 2.4.4, win32),
Five 1.3.8,
Python 2.4.4 (#71, Oct 18 2006, 08:34:43) [MSC v.1310 32 bit (Intel)],
PIL 1.1.5
Added by Maurits van Rees on Dec 13, 2007 11:48 PM
Severity: ImportantMedium
Target release: 1.1None
Responsible manager: maurits(UNASSIGNED)
I do not get this error. And it is so deep in Zope that it is likely not a Poi bug. You could google for it or ask on the plone-users or zope-user mailing list or look at this similar issue with quills: http://plone.org/products/quills/issues/45 though that issue does not provide definite answers.

I will keep this report open for now, but I do not expect we can do anything about this in Poi.
Added by Maurits van Rees on Dec 21, 2007 09:51 PM
Issue state: unconfirmedopen
Target release: None1.1
Responsible manager: (UNASSIGNED)maurits
Actually, with the versions you gave, I can reproduce this. So I will look into it.
Added by Maurits van Rees on Dec 21, 2007 10:01 PM
Issue state: openin-progress
Severity: MediumImportant
Grrrm, it stumbles over the ExpressionValidator I added to two fields of the PoiTracker. :-(
Added by Maurits van Rees on Dec 21, 2007 11:23 PM
Issue state: in-progressresolved
Fixed in r56071. Sorry for initially misinterpreting this as some weird Zope undebuggable bug and not even *trying* to reproduce it. I will release a fourth release candidate shortly.
Added by Maurits van Rees on Dec 22, 2007 01:02 AM
Improved (mostly more tests) in r56087.

No responses can be added.