#42 — Error with two inbound feeds

State Resolved
Version: 2.0.8
Area Functionality
Issue type Bug
Severity Medium
Submitted by richardc
Submitted on Nov 11, 2012
Responsible Maurits van Rees
Target release: 2.0.9
Hi,

I get the following error on updating either of the following feeds in feedfeeder:

http://feeds.panda.org/wwf/water
http://feeds.panda.org/wwf/marine

Traceback (innermost last):
  Module ZPublisher.Publish, line 126, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 46, in call_object
  Module Products.feedfeeder.browser.feed, line 46, in __call__
  Module Products.feedfeeder.browser.feed, line 43, in update
  Module Products.feedfeeder.utilities, line 98, in retrieveFeedItems
  Module Products.feedfeeder.utilities, line 324, in _retrieveSingleFeed
TypeError: not all arguments converted during string formatting

System: Plone 4.1.5
Steps to reproduce:
1. Add feed to 'Feeds' field under edit tab
2. Actions > Update feed items
Added by Maurits van Rees on Nov 12, 2012 11:17 AM
Issue state: UnconfirmedResolved
Responsible manager: (UNASSIGNED)maurits
Oops, the code there tries to log a warning but this has an error. I have fixed it and released version 2.0.9.

Note that this code tries to warn you that a UnicodeDecodeError has occured, which probably means that the feed itself has an error. After the fix, I see two of those warning messages appear for your feeds. The items do end up in the website, so it seems it is not too bad.
Added by Maurits van Rees on Nov 12, 2012 11:18 AM
Target release: None2.0.9

No responses can be added.