Plone 3.2 released

An update with improvements to packaging and better support for right-to-left scripts like Arabic and Hebrew.
The Plone Team is excited to announce the release of Plone 3.2! This release is mostly focused on unifying the dependency and package management across all platforms. All the installers (Windows, Mac, Linux/BSD/UNIX) are now based on the Unified Installer, and they are all using "Buildout": for configuration/deployment management. Additionally, the Mac OS X installer ships with both Intel and PPC binaries in the same download. "Download Plone 3.2": Who should upgrade? With the changes in this release, it might be worth blocking out some extra time to perform the upgrade and/or hold off a little while, depending on your situation. **You definitely want to upgrade if:** - You are running a site that uses right-to-left scripts like Arabic or Hebrew. - You want to run the same setup across multiple platforms. - You want to have a future-proof setup that you can upgrade with a simple change of the configuration file. **You might want to hold off on the upgrade for a little bit if:** - You are uncomfortable using Plone on Windows without the Plone Controller application (the one with the start/stop/restart controls), or if you are at all allergic to the command line on Windows. The Plone Controller will be back soon, we promise! - You have a complex setup and can't block off a little time right now to convert it to a Buildout-based setup. Common Questions How do I upgrade my previous install to the new setup? I hear that I can't just install it on top of the old version? -- Correct, the best way to upgrade is to install a clean new instance, get it working with all the products you need, and then move over your Data.fs file and upgrade as usual. More information can be found in the "upgrade documentation": After making this change, future upgrades will be very simple. Why did you ship the Windows installer without the Plone Controller? -- We were hoping that it would be done in time, but it took a bit longer than expected — and we didn't want to hold back the other platform releases just because of it. We are working on adding it back — and it should be available very soon. I don't want to upgrade from Plone 3.1 just yet — am I missing out on anything? Will there be products that require Plone 3.2? -- No, products that work with Plone 3.2 should work on Plone 3.1 and 3.0 too. So if you want to give yourself some more time before you move to Buildout, or you want to wait until the Plone Controller is ready for Windows, feel free to postpone your upgrade a little bit. What happened to Plone 3.2.0? I only see Plone 3.2.1? -- Plone 3.2.0 omitted the NuPlone theme by mistake — which isn't critical, but we decided to quickly push out a 3.2.1 release to fix it instead. Why are you so excited about Plone 3.2 when the only changes are to packaging? -- It makes it much easier for documentation to be consistent across platforms (they are all using Buildout now), upgrades are much easier in the future (change version string in the configuration, re-run buildout, and you are upgraded) and deployments are very easy to put under version control. It also lets you manage Apache/Varnish/Squid and similar setups from a central, version-controlled location. There are lots of awesome things about Buildout, for the full lowdown, consult the "Plone Buildout documentation": Is there a cheat sheet available for Buildout? I'm in a hurry and/or I'm too smart for real documentation. -- We're happy you asked — in fact, we have your "Buildout Quick Reference card": right here. Print the free PDF, or order the laminated versions — perfect for your coffee-soaked desk, your yacht and your mountain-top lair. Get three! Any proceeds go directly to the Plone Foundation. Any other questions? Leave a comment below. No questions? Then, what are you waiting for? "Download Plone 3.2":