#223 — If a user enters an unusable email address when creating an issue, no changes can be made to that issue.

by Derek Broughton last modified Aug 31, 2009 10:16 PM
State Resolved
Version: 1.2
Area Functionality
Issue type Bug
Severity Medium
Submitted by Derek Broughton
Submitted on Aug 31, 2009
Responsible Maurits van Rees
Target release: 1.2
We have an Intranet behind a firewall which prevents our SMTP server sending email to addresses outside our domain. It's possible for me to create an issue using such an address - it's a perfectly valid address - but any attempt to further modify the issue results in the following error. It should not be possible to enter an email address that will generate a fatal error in future. Poi should either validate the email address on entry (perhaps by simply emailing the reporter a confirmation that the issue is accepted) or fail more gracefully on updates.

Traceback (innermost last):
  Module ZPublisher.Publish, line 119, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 42, in call_object
  Module Products.Poi.browser.response, line 447, in __call__
  Module Products.Poi.adapters, line 98, in add
  Module zope.event, line 23, in notify
  Module zope.component.event, line 26, in dispatch
  Module zope.component._api, line 131, in subscribers
  Module zope.component.registry, line 300, in subscribers
  Module zope.interface.adapter, line 535, in subscribers
  Module zope.component.event, line 33, in objectEventNotify
  Module zope.component._api, line 131, in subscribers
  Module zope.component.registry, line 300, in subscribers
  Module zope.interface.adapter, line 535, in subscribers
  Module Products.Poi.events, line 50, in addedNewStyleResponse
  Module Products.Poi.events, line 141, in sendResponseNotificationMail
  Module Products.Poi.content.PoiTracker, line 436, in sendNotificationEmail
  Module Products.SecureMailHost.SecureMailHost, line 238, in secureSend
  Module Products.SecureMailHost.SecureMailHost, line 268, in _send
  Module Products.SecureMailHost.mail, line 132, in send
  Module smtplib, line 695, in sendmail
SMTPRecipientsRefused: {u'derek@pointerstop.ca': (550, '5.7.1 Relaying not allowed contact MAR Helpdesk: derek@pointerstop.ca')}
Steps to reproduce:
It should be possible to cause the same result by using a syntactically correct, but non-existent email address - ie, anything that will generate an error in the SMTP dialog.

Added by Derek Broughton on Aug 31, 2009 02:03 PM
On second thoughts, it should _always_ just fail more gracefully on updates, because it is possible that the address may have become invalid in the period between creation of the issue, and updating the issue.
Added by Maurits van Rees on Aug 31, 2009 02:44 PM
Issue state: UnconfirmedConfirmed
Responsible manager: (UNASSIGNED)maurits
Target release: None1.2
Hm, at that spot Poi is trying to catch an error, but not this one. I'll see about adding this error.
Added by Maurits van Rees on Aug 31, 2009 10:16 PM
Issue state: ConfirmedResolved
Fixed in r96308.

No responses can be added.