#218 — No state change on the response form

by Dylan Jay last modified Jan 06, 2010 04:10 PM
State Resolved
Version:
Area Functionality
Issue type Bug
Severity Important
Submitted by Dylan Jay
Submitted on Jul 06, 2009
Responsible Maurits van Rees
Target release: 1.2
I uploaded a product and then added a issue tracker. I have no state change dropdown in the response form. Permissions must have got mucked up some how. Not sure where it went wrong.

http://plone.org/products/collective.hostout/issues
Added by Maurits van Rees on Jul 06, 2009 10:42 AM
Issue state: UnconfirmedConfirmed
Responsible manager: (UNASSIGNED)maurits
Well, it is not a drop down, but a radio button, but anyway...

You are sure you are logged in as user that has the local Manager role?

Do you see the other manager options? That is:
- Change issue severity
- Change target release
- Change responsible manager

Is it perhaps working correctly on old.plone.org?
Added by Dylan Jay on Jul 06, 2009 01:54 PM
On the issue tracker itself I see Edit and sharing tabs etc so I assume that means I have manager role.
On the issue itself I don't see severity, target release or anything other than response field. Pretty much exactly the same as I see in this response form on this tracker. Perhaps the issue itself has weird permissions?

old.plone.org has the same behaviour.
Added by Maurits van Rees on Jul 06, 2009 08:52 PM
I do not have these problems in the poi tracker itself. It might be that new trackers suffer from this problem but that would be strange.

You can look at the security tab of the issue or tracker in the ZMI. Look for the settings for 'Poi: Modify issue state'.

To go to the ZMI you will have to use old.plone.org as manage_main does not render anything useful on plone.org...
Added by Dylan Jay on Jul 07, 2009 12:35 AM
I can see the zmi for the tracker and the issue but the security tab doesn't show up.
Every tab except the security tab is shown I believe. I am set to be the owner of the tracker.
Added by Maurits van Rees on Jul 08, 2009 11:12 PM
Issue state: ConfirmedIn progress
Target release: None1.2
You *should* be able to see the Security tab in the ZMI. I just tested it locally and there it works.

Hm, wait a minute, I get the same results as you when (as admin user) I make another user not Manager but Owner (via the ZMI).

It seems I'll have to check what happens here with Poi in combination with PloneSoftwareCenter, or otherwise when a non-Manager adds a Poi tracker: he will then be Owner, but is apparently not made Manager. Yes, that is what is happening.

I am not sure yet if I should improve the code that is called when a tracker is added or if I should change the workflow permissions. Probably the first one though.

For now a workaround will have to do. For you that would be: make *me* (or someone else) a Manager of your tracker. Then I remove you and add you again. That *should* give you proper Manager rights. Then you can remove me again.

Or actually: just removing yourself as manager and then adding yourself again works too when you are Owner. For safety you can temporarily add me as manager first though.
Added by Maurits van Rees on Aug 31, 2009 11:17 PM
Issue state: In progressResolved
Severity: MediumImportant
Strange that this has not surfaced sooner, as this problem already exists on Plone 2.5 with Poi 1.1.2 (and probably earlier too).
Fixed on trunk, together with some possible other errors in this area, in r96313.
Added by Kees Hink on Jan 06, 2010 02:08 PM
+1 for http://plone.org/products/plone-invite/issues (khink)

Fixed by Maurits (after help on IRC): I should've changed the list "tracker managers" in the 'issues/edit' form. Thanks again.

No responses can be added.