Plone 3.2.1 (Feb 07, 2009)

Warning

This is an historical page intended for people who can't upgrade. Current versions of Plone can be found on the overview page

Maintenance release for the Plone 3.2.x series

For additional information about this project, please visit the overview page .

For installation instructions go to: http://docs.plone.org/manage/installing.

There may be hotfixes applicable to this release. Always check the Plone Hotfix Page before production deployment.

Available downloads

Release Notes

State Final release
License GPL
Release Manager Wichert Akkerman
Released 2009/02/04 00:00:00 Universal

Beginning with Plone 3.2, Plone will be available as a Python package and via installers. It will no longer be distributed as a tarball of old-fashioned Zope products. The change to standard Python packaging will improve dependency handling and make future installations easier. But, it will require some adjustments for those used to installing via a tarball of products. The 3.2 installation will also require some slight changes in the buildout configuration file for those who have already been using buildout configuration management in the 3.x series.

Windows Update

Users of past Windows installers should note: you should not try to simply install on top of your old Windows installation. That might have worked in the past, but it won't work with this upgrade. The move to a buildout-based installer has changed the layout of the subdirectories inside the installation. Do a new installation, get it working with all required products, then copy your old Data.fs file over the matching file in the new installation.

More information

More information on upgrading to Plone 3.2.x can be found in the upgrade guide

Change log

  • Add missing security declaration for session setup. Fixes possible privilege escalation if untrusted people have Manager access as either a global or local role.
  • Add dependency on NuPlone to Plone so installs using NuPlone do not break on upgrade if they forgot to declare the dependency themselves.
  • Work around IE6 background caching problem. Fixes 7445.
  • Many right-to-left language improvements. Fixes 4570, 6368, 8863
  • Display swf (flash) files inline so they work with Adobe Flash 10 and later. Fixes 8624.

Upgraded packages

  • Plone 3.2.1
  • Products.ATContentTypes 1.2.6
  • Products.NuPlone 1.0b3
  • kss.core 1.4.5
  • plone.session 2.1