#219 — content not switching language

by Megan Butcher last modified Oct 22, 2009 07:42 PM
State Resolved
Version: 3.x
Area Functionality
Issue type Bug
Severity Medium
Submitted by Megan Butcher
Submitted on Sep 30, 2009
Responsible
Target release: 3.x
When I switch from one language to the other, the portal top and thin (right-hand, for me) column change language, but the content in the main (left-hand, for me) column does not.

This was logged a while ago on the Internationalization support forum (http://n2.nabble.com/Lingua[…]roblem-tp230476p230476.html). I searched through the current and past issues in this space and didn't find anything matching my issue.

I've been in touch with owner of the theme I'm using, who indicated that it was an LP problem. Also been in touch with the person who logged the issue on the forum - his fixes so far haven't worked with my versions.

Since it seems to be a problem with more than one theme, I'm wondering if it is indeed an LP bug.


Using...
Plone: 3.3
LinguaPlone: 2.x
Theme: webcouturier.icompany.theme 1.1

Added by Hanno Schlichting on Oct 02, 2009 05:33 PM
Issue state: UnconfirmedConfirmed
Please go to your site into the ZMI and look at the language negotiation settings you have. You can reach those at http://<your site>/portal_languages/manage_configForm

In the negotiation section try enabling the entry marked:

"Use the language of the content item."

Make sure that:

"Use cookie for manual override."

is activated as well.

If this doesn't produce the expected result, please add your negotiation settings to this ticket and note in detail what kind of object you are looking at, in which languages it is translated and how exactly you switch from one language to the other.
Added by Megan Butcher on Oct 02, 2009 06:49 PM
With "Use the language of the content item" enabled, when I click from e.g. English to French, nothing happens at all.

Right now, the only things enabled in my negotiation settings is "Use cookie for manual override."

As well, under Content Control Settings, I've enabled "Force different URLs for each language." and "Create content initially as neutral language."

I'm looking at a page that is the default view of a folder. Both the folder and the page were created in English first and then translated into French. I switch from English to French (or vice versa) using a drop down menu in the portal top. Using the flags doesn't change behaviour at all.

Thanks very much.
Added by Hanno Schlichting on Oct 22, 2009 07:42 PM
Issue state: ConfirmedResolved
Target release: None3.x
I fixed the selector logic in SVN to actually do something again in the common scenario. It was indeed broken. This will be released as part of 3.0b8.

No responses can be added.