#207 — Code in README.txt fails to import LinguaPlone

State Resolved
Version:
Area Functionality
Issue type Bug
Severity Medium
Submitted by Philip Bauer
Submitted on Mar 10, 2009
Responsible
Target release:
There is a fatal error in LinguaPlone/README.txt

Instead of adding
try:
    from Products.LinguaPlone.atapi import *
except ImportError:
    # No multilingual support
    from Products.Archetypes.public import *

it rather should be
try:
    from Products.LinguaPlone.public import *
except ImportError:
    # No multilingual support
    from Products.Archetypes.atapi import *

Since LinguaPlone has no 'atapi' the above code fails silently. One annoying side-effect would be, that values of custom languageIndependent fields are not syncronised when the canonical version is edited.
Added by Thomas Kiser on Mar 13, 2009 11:58 AM
In one of my Products I use:

try:
    from Products.LinguaPlone.public import *
except ImportError:
    # No multilingual support
    from Products.Archetypes.public import *

-> Twice "public". Anything wrong about that?
Added by Thomas Kiser on Mar 13, 2009 11:59 AM
In one of my Products I use:

try:
    from Products.LinguaPlone.public import *
except ImportError:
    # No multilingual support
    from Products.Archetypes.public import *

-> Twice "public". Anything wrong about that?
Added by Philip Bauer on Mar 16, 2009 08:35 AM
No. Archetypes has a public.py for backward compatibility reasons. It only consits of "from Products.Archetypes.atapi import *"
Philip
Added by Hanno Schlichting on Sep 25, 2009 04:29 PM
Issue state: UnconfirmedResolved
Fixed this on trunk, thanks! Will be released in 3.0b3.

No responses can be added.