#36 — Provide Plone4 content-core metal slot (for compatibility with collective.blog.view)

State Resolved
Version: 2.0.4
Area Functionality
Issue type Bug
Severity Medium
Submitted by Domen Kožar
Submitted on Jun 14, 2011
Responsible Maurits van Rees
Target release: 2.0.5
This is how collective.blog.view fails to find content-core slot:

http://dev.plone.org/[…]/default_item.pt
Steps to reproduce:
Install feedfeeder and collective.blog.view and provide blog view for feeder items.
Added by Maurits van Rees on Jun 17, 2011 12:27 AM
I quickly tried a few things, but did not get any result, only tracebacks. A patch that works on Plone 4 and (preferably) Plone 3 is welcome.
Added by Domen Kožar on Jun 17, 2011 11:44 AM
I have zero experience with writing Plone 4 and 3 compatible templates. Some references or tutorials are welcome :)

Let me explain my effort so far:

Changed content_macro to content_macros and triggered pdb in the namespace scope of that template. It seems only base_macros var is not None, having the only 'body' element. This is rather wierd to me.

If feedfeeder would provide just content-core macro independently of Plone 3 template, that would be the best solution I can think of.
Added by Maurits van Rees on Sep 03, 2011 01:15 AM
Issue state: UnconfirmedResolved
Responsible manager: (UNASSIGNED)maurits
Added our own documentbyline viewlet in r244107.
Using a different template in Plone 3 and 4 in r244109.
I think that fixes this.

This will be in the soon-to-be-released 2.0.5 release.
Added by Maurits van Rees on Dec 27, 2011 10:16 PM
Target release: None2.0.5
This fix is in 2.0.5.

2.0.7 is the most recent release (made today).

No responses can be added.