collective.jqueryui.autocomplete

by Luca Fabbri last modified Dec 01, 2011 11:11 AM

jQueryUI for Plone, limited at minimal to provide only autocomplete feature

Project Description

Introduction

Add to your Plone site the minimal code needed to have the jQueryUI Autocomplete feature.

This product is targeted on developers. This simply add to Plone a new JavaScript source and the basical CSS needed to see a pretty autocomplete dropdown.

Warnings

When you DON'T need this

You must not install this product if your Plone site already have other jQueryUI products like:

All products above have some drawbacks. For example latest collective.js.jqueryui doesn't play well with Plone 3 (and the Plone 3 compatible version doesn't include autocomplete plugin yet).

On the other hand collective.javascript.jqueryui cleaner but don't register any resource.

When you need this

You need to use jQueryUI autocomplete but you don't want to include the whole jQueryUI stuff that products above give you.

Authors

This product was developed by RedTurtle Technology team.

RedTurtle Technology Site

Self-Certification

[ ] Internationalized

[ ] Unit tests

[X] End-user documentation

[ ] Internal documentation (documentation, interfaces, etc.)

[X] Existed and maintained for at least 6 months

[X] Installs and uninstalls cleanly

[X] Code structure follows best practice

Current Release

No stable release available yet.

All Releases

Version Released Description Compatibility Licenses Status
0.1.0 Initial version More about this release…
Plone 4.1
Plone 4
Plone 3
GPL beta